社内メールの宛先を変更すると、その社内メールを未受信のユーザーが、社内 メールを正常に使用できなくなる場合がある。
- 種別
- 不具合
- 機能
-
- メッセージ
- 再現バージョン
-
- 2.5.3
- 改修バージョン
- 2.5.4
- 公開日
- 2009-11-11
- 更新日
- 2010-05-07
詳細
【現象】
社内メールの宛先を変更すると、その社内メールを未受信のユーザーが、社内
メールを正常に使用できなくなる場合がある。
【発生条件】
次の条件を満たす社内メールが存在する場合に、その社内メールを未受信の
ユーザーで、現象が発生します。
1. 2.5.1以前のバージョンで、未受信の社内メールが存在する
2. 2.5.3にバージョンアップ後、条件1を満たす社内メールの
宛先を変更する
※未受信の社内メールとは、宛先に入っている社内メールのうち、通知や
詳細を一度も閲覧していない社内メールです。
【事前準備】
1. 2.5.1以前のバージョンにユーザー1でログインし、「トップページ >
社内メール > 受信箱 > 社内メールの作成」画面を開く
2. 次の内容で社内メールを送信する
----------------
標題:テスト1
本文:本文1
宛先:ユーザー2、ユーザー3
----------------
【再現手順】
1. 2.5.3にバージョンアップする
2. ユーザー1でログインし、事前準備で送信した社内メールを開く
3. 「宛先を変更する」をクリックし、宛先をユーザー4を追加する
4. ユーザー2またはユーザー3でログインし、「トップページ > 社内メール」
画面を開く
→現象発生
次のエラーが表示される。
エラー (DB01062)
値が重複しています。
※ログイン時に表示されるポータルに、次のポートレットを配置して
いる場合は、手順4でログイン時にエラーが発生します。
・最新情報ポートレット
・社内メールポートレット
・未確認社内メールポートレット
回避/対応方法
【対応方法】
現象の発生条件を満たす社内メールを送信者が削除することで、現象が発生
したユーザーが「ガルーン 2」にログインできます。
※社内メールを削除する場合は、「受信者のフォルダからも完全に削除する」の
チェックを入れて削除してください。
※該当する社内メールのデータが必要な場合は、社内メールを削除する前に、
「社内メールの詳細」画面からファイルに出力、および添付ファイルを保存
してください。
※社内メールの送信者は、次の手順で確認できます。
1. 「ガルーン 2」にログインしてエラーメッセージを表示し、社内メールの
IDを確認する
例:
エラ-(DB01062)
値が重複しています。
原因
Duplicate entry '65-0-174496' for key 2
→「174496」が社内メールのIDです。
2. 「Administrators」ロールを持つユーザーで、次のURLにアクセスする
http://(インストールしたサーバーのIP アドレスまたはホスト名)/scripts/cbgrn/grn.exe/message/system/inspection_view?mid=手順1で確認した社内メールID
http://(インストールしたサーバーのIP アドレスまたはホスト名)/cgi-bin/cbgrn/grn.cgi/message/system/inspection_view?mid=手順1で確認した社内メールID
※既定のインストール識別子(cbgrn)を使用してインストールした場合のURLです。
例:Windows環境で社内メールIDが「174496」の場合
http://cybozu-garoon2/scripts/cbgrn/grn.exe/message/system/inspection_view?mid=174496
→該当の社内メールの「社内メールの詳細」画面が開かれます。
3. 社内メールの差出人を確認する
4. 社内メールの差出人で該当の社内メールを削除する