001-003947
書込権限がないユーザーでファイルの更新画面が表示され、操作するとファイルがロックされて編集できなくなる場合がある。
- 種別
- 不具合
- 機能
-
- ファイル管理
- 再現バージョン
-
- 3.0.0
- 3.0.1
- 3.1.0
- 3.1.1
- 改修バージョン
- 3.1.2
- 公開日
- 2010-10-20
- 更新日
- 2011-08-19
詳細
【発生条件】
次の条件を満たす場合に発生します。
- ファイルのロック機能を有効にする。
- システム管理画面にログインし、[基本システムの管理] > [ファイル] > [一般設定]の順にクリックします。
- ロック機能の「使用する」のチェックボックスを選択します。
- システム管理画面にログインし、[基本システムの管理] > [ファイル] > [一般設定]の順にクリックします。
【準備】
- システム管理画面で、[各アプリケーションの管理] > [ファイル管理] > [フォルダの設定] > [フォルダを追加する]の順にクリックします。
- フォルダ情報を入力し、[追加する]をクリックします。
例:
フォルダ1 - システム管理画面で、[各アプリケーションの管理] > [ファイル管理] > [アクセス権の設定]を順にクリックします。
- フォルダ1を選択し、[設定する]をクリックします。
- 閲覧のみ可能なユーザーと閲覧と書き込みが可能なユーザーを追加します。
例:
------------------------------------
セキュリティモデル:GRANT(許可の対象を選択する)
ユーザー 1:閲覧✓ 書き込み×
ユーザー 2:閲覧✓ 書き込み✓
------------------------------------ - アプリケーション画面に、ユーザー2でログインします。
- フォルダ1にファイルを追加します。
【再現手順】
- アプリケーション画面に、ユーザー1でログインします。
- フォルダ1を開きます。
- ファイルのタイトルの右にある更新アイコンをクリックします。
→現象発生:
書き込み権限がないユーザー1で、「ファイルの更新」画面が表示されます。
補足:
- 「ファイルの更新」画面で、[更新する]または、[キャンセルする]をクリックした場合、次のエラーが発生し、ロックを解除できません。
------------------------------------
エラー (GRN_CBNT_17009)
指定されたフォルダにはファイルを追加できません。
原因
現在ログイン中のユーザーには、このフォルダにファイルを追加する権限がありません。
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回避/対応方法
【対応方法】
- ロックをかける期間を設定します。
- システム管理画面にログインし、[基本システムの管理] > [ファイル] > [一般設定]の順にクリックします。
- 「ロックを掛ける期間」のプルダウンメニューで[(無制限)]以外を選択します。
- システム管理画面にログインし、[基本システムの管理] > [ファイル] > [一般設定]の順にクリックします。
- システム管理者がロックを解除します。
- システム管理画面にログインし、[各アプリケーションの管理] > [ファイル管理] > [フォルダの設定]の順にクリックします。
- フォルダ1を選択します。
- 手順7で追加したファイルをクリックします。
- [編集中を解除する]をクリックします。
- システム管理画面にログインし、[各アプリケーションの管理] > [ファイル管理] > [フォルダの設定]の順にクリックします。
- 運用管理者でロックを解除します。
- アプリケーション画面に、運用管理者でログインします。
- 手順7で追加したファイルをクリックします。
- [編集中を解除する]をクリックします。
- アプリケーション画面に、運用管理者でログインします。
- ファイルのロック機能を無効にします。