001-005469
「電話メモ」ポートレットで、アクセス権がないユーザーの「登録」「一覧」リンクが無効化されない。
- 種別
- 不具合
- 機能
-
- ポートレット
- 電話メモ
- 再現バージョン
-
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.7.0
- 3.5.5
- 3.7.1
- 3.7.2
- 3.7.3
- 3.7.4
- 3.7.5
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.10.0
- 4.10.1
- 4.10.2
- 4.10.3
- 5.0.0
- 5.0.1
- 5.0.2
- 5.5.0
- 5.5.1
- 5.9.0
- 5.9.1
- 5.9.2
- 5.15.0
- 5.15.1
- 5.15.2
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 改修バージョン
- 公開日
- 2012-04-19
- 更新日
- 2012-04-19
詳細
【準備】
- 次のユーザーを作成します。
- ユーザーA
- ユーザーB
補足:
ユーザーAとユーザーBは同じ組織に所属します。
- 電話メモで、次のアクセス権を設定します。
- 「ユーザーB」に対するアクセス権
- セキュリティモデル:REVOKE
- 対象:ユーザーA
閲覧×、登録×
- 「ユーザーB」に対するアクセス権
- ユーザーAのポータルに「電話メモ」ポートレットを追加します。
【再現手順】
- ユーザーAでアプリケーション画面にログインし、「電話メモ」ポートレットを確認します。
→現象発生:
ユーザーBの[登録]、[一覧]リンクが表示されます。
→正しい結果:
ユーザーBの[登録]、[一覧]リンクは無効化されます。
補足:
- ポートレット内に表示される[登録]、[一覧]リンクをクリックすると、次のエラーが表示されます。
----------------------
エラー (GRN_PHNM_19301)
電話メモを登録できません。
原因
現在ログイン中のユーザーには、この組織/ユーザー/ロールに電話メモを登録する権限がありません。
---------------------- - ログインユーザー自身が所属する組織に対して「準備」と同じアクセス権を設定した場合も同様の現象が再現します。
- 「電話メモ」アプリケーションの画面内では、ユーザーBの[登録]、[一覧]リンクは無効化されます。
回避/対応方法
【回避方法】
セキュリティモデルがGRANTの場合は現象が発生しないため、アクセス権の設定時にセキュリティモデルをGRANTにしてください。