001-008691
施設グループや施設を移動すると、施設予約の設定が正しく反映されない場合がある。
- 種別
- 不具合
- 機能
-
- スケジュール
- システム設定
- 再現バージョン
-
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.5
- 3.7.0
- 3.7.1
- 3.7.2
- 3.7.3
- 3.7.4
- 3.7.5
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 改修バージョン
- 4.2.0
- 公開日
- 2015-09-25
- 更新日
- 2015-09-29
詳細
【発生条件】
次の条件をすべて満たす場合に発生します。
- 施設または子施設グループが存在する子施設グループを移動する。
- 移動後の親施設グループが「親施設グループの内容を反映する」設定になっている。
【準備】
- 施設グループを追加します。
例:
------------
(トップ)
└施設グループ1
│ └ 施設グループ2
└ 施設グループ3
------------
補足:
- (システム管理画面)「スケジュール > 施設/施設グループ > 施設グループの追加」画面で追加します。
- (システム管理画面)「スケジュール > 施設/施設グループ > 施設グループの追加」画面で追加します。
- 施設グループ2の配下に、施設を追加します。
例:
------------
(トップ)
└施設グループ1
│ └ 施設グループ2
│ └ 施設1
└施設グループ3
------------
補足:
- (システム管理画面)「スケジュール > 施設/施設グループ > 施設の追加」画面で追加します。
- (システム管理画面)「スケジュール > 施設/施設グループ > 施設の追加」画面で追加します。
- (システム管理画面)「スケジュール > 施設予約の設定 > 設定の変更」画面で、施設グループ1の予約設定の情報を設定します。
例:
- 施設グループ1
- 設定の継承:「親施設グループの内容を反映する」のチェックボックスの選択を外す
- 予約設定の可能な期間:1ヶ月
- 予約設定の可能な最大時間:1時間00分
- 予約を変更可能なユーザー:予約者のみ
- 施設グループ1
- (システム管理画面)「スケジュール > 施設予約の設定 > 設定の変更」画面で、施設グループ2と施設1の予約設定の情報に、施設グループ1の予約設定の情報が継承されていることを確認します。
例:
- 施設グループ2
- 設定の継承:「親施設グループの内容を反映する」のチェックボックスを選択する
- 予約設定の可能な期間:1ヶ月
- 予約設定の可能な最大時間:1時間00分
- 予約を変更可能なユーザー:予約者のみ
- 設定の継承:「親施設グループの内容を反映する」のチェックボックスを選択する
- 施設1
- 設定の継承:「親施設グループの内容を反映する」のチェックボックスを選択する
- 予約設定の可能な期間:1ヶ月
- 予約設定の可能な最大時間:1時間00分
- 予約を変更可能なユーザー:予約者のみ
- 設定の継承:「親施設グループの内容を反映する」のチェックボックスを選択する
- 施設グループ2
【再現手順】
- システム管理画面にログインし、[各アプリケーションの管理] > [スケジュール] > [施設/施設グループ] > [施設グループ2] > [詳細] > [施設グループを移動する]の順にクリックします。
- 移動後の親施設グループに「施設グループ3」を選択し、[移動する]をクリックします。
- [各アプリケーションの管理] > [スケジュール] > [施設予約の設定]の順にクリックします。
- 施設グループ3の左にある[+]をクリックし、フォルダツリーを展開します。
- ツリーの[施設グループ2]をクリックします。
→現象発生:
施設1の予約設定の情報に、施設グループ1の予約設定の情報が継承されたままとなっています。
例:
- 施設1
- 可能期間:1ヶ月
- 最大時間:1時間00分
- 変更可能ユーザー:予約者のみ
→正しい結果:
施設1の予約設定の情報に、施設グループ3の予約設定の情報が継承されます。
例:
- 施設1
- 可能期間:無期限
- 最大時間:無期限
- 変更可能ユーザー: アクセス権のあるすべてのユーザー
補足:
- 現象発生後、施設の予約時間が最大時間を越える、施設1を含む予定を登録すると、次のエラーが発生します。
例:
------------
エラー (GRN_SCHD_13218)
施設を含む予定の最大時間を超えています。
原因
施設の予約時間は 施設1:60分までしか登録できない設定になっています。
------------ - 施設グループ2の配下の子施設グループを、施設グループ3の配下に移動した場合も、同様の現象が発生します。
回避/対応方法
【対応方法】
次の操作で、施設1の予約設定の情報が正しく反映されます。
- システム管理画面にログインし、[各アプリケーションの管理] > [スケジュール] > [施設予約の設定]の順にクリックします。
- 施設グループ3の左にある[+]をクリックし、フォルダツリーを展開します。
- ツリーの[施設グループ2]をクリックします。
- [施設1]をクリックします。
- 何も変更せずに[変更する]をクリックします。
------------------------------------------------------------
【更新履歴】
2015/09/29 正しい結果を更新しました。