001-010258
スペースのメンバーであるユーザーを削除したあと、復旧しても、スペースのメンバーに表示されない場合がある。
- 種別
- 不具合
- 機能
-
- スペース
- ユーザー
- 再現バージョン
-
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 改修バージョン
- 4.10.0
- 公開日
- 2018-07-19
- 更新日
- 2018-10-19
詳細
【準備】
- ユーザーを追加します。
例:
- ユーザー1
- ユーザー2
- ユーザー1で、メンバーにユーザー2を含むスペースを作成します。
例:
----------
スペース名:スペース1
メンバー:ユーザー1、ユーザー2
---------- - ユーザー2を削除します。
補足:
- 「削除されたユーザーのデータ」は削除しない状態のままにします。
次の操作で確認できます。
- [基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- データを削除するユーザーで、 「ユーザー2」が表示されていることを確認します。
- [基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- 「削除されたユーザーのデータ」は削除しない状態のままにします。
- スペース1の「メンバーの変更」画面で、[変更する]をクリックします。
【再現手順】
- システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- 「ユーザー2」のチェックボックスを選択し、[復旧する] > [はい]の順にクリックします。
- ユーザー1でアプリケーション画面にログインし、[スペース] > [すべてのスペース] > [スペース1]の順にクリックします。
- スペース1のメンバーを確認します。
→現象発生:
手順2で復旧したユーザー2が、スペース1のメンバーに表示されていません。
補足:
- 現象発生後、復旧したユーザー2をスペース1のメンバーに追加しようとすると、次のエラーが発生し、ユーザー2をメンバーに追加できない現象が発生します。
---------
エラー (DB01062)
値が重複しています。
原因
Duplicate entry '5-3' for key 'PRIMARY'
---------
- 手順2のあと、ユーザー2でスペース1に参加しようとした場合も、エラー(DB01062)が発生します。
回避/対応方法
【回避方法】
次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。
次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。
- バージョン 4.10.0のGaroon
------------------------------------------------------------
【更新履歴】
2018/08/20 タイトルと現象を更新しました。