001-004544
閲覧可能なレポートをクリックしても、エラーが表示されてレポートを閲覧できない場合がある。
- 種別
- 不具合
- 機能
-
- マルチレポート
- 再現バージョン
-
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 改修バージョン
- 3.1.1
- 公開日
- 2011-07-01
- 更新日
- 2011-07-19
詳細
【発生条件】
- カテゴリIDの十の位と同じ値の1桁のカテゴリIDを持つアクセス権のないカテゴリが存在する
【準備】
- システム管理画面で、[各アプリケーションの管理] > [マルチレポート] > [レポートフォームの一覧]の順にクリックします。
- 次のカテゴリを作成します。
- カテゴリを作成した時に、割り振られるカテゴリIDが2から20までの19個のカテゴリを作成します。
補足:
- カテゴリIDはカテゴリを選択したときのURLに表示されます。
- カテゴリIDが2の場合に「レポートフォームの詳細」画面を開いたURLは次のとおりです。
http://(インストールしたサーバーのIP アドレスまたはホスト名)/cgi-bin/cbgrn/grn.cgi/report/system/form_list?cid=2
- カテゴリIDが20のカテゴリ内に、レポートフォームを作成します。
- 手順4で作成したレポートフォームを有効にします。
- [基本システムの管理] > [ユーザー] > [組織/ユーザーの設定]の順にクリックします。
- 次のユーザーを作成します。
- ユーザー1
- ユーザー2
- [各アプリケーションの管理] > [マルチレポート] > [アクセス権の設定]の順にクリックします。
- ユーザー1とユーザー2が、ID 2のカテゴリにアクセスできない設定にします。
補足:
- カテゴリIDが2の場合に「アクセス権の設定」画面を開いたURLは次のとおりです。
http://(インストールしたサーバーのIP アドレスまたはホスト名)/cgi-bin/cbgrn/grn.cgi/report/system/access_index?nid=2
- カテゴリIDが2の場合に「アクセス権の設定」画面を開いたURLは次のとおりです。
【再現手順】
- アプリケーション画面に、ユーザー1でログインします。
- 準備の手順4で作成したレポートフォームで、ユーザー2を通知先に含めないレポートを作成します。
- アプリケーション画面に、ユーザー2でログインします。
- [マルチレポート] > [閲覧可能なレポート]の順にクリックします。
- 手順2で作成したレポートをクリックします。
→現象発生:
次のエラーが表示されます。
-------------------------------
エラー (GRN_RPRT_31154)
指定されたレポートはアクセスできません。
原因
現在ログイン中のユーザーには、このレポートに対してアクセスする権限がありません。
-------------------------------
回避/対応方法
【対応方法】
- 「参加者以外の通知先」にレポートを閲覧できないユーザーを追加します。
- ユーザー1で、再現手順の手順2で作成した「レポートの詳細」画面を表示します。
- [変更する]をクリックします。
- 「参加者以外の通知先」にユーザー2を追加し、[変更する]をクリックします。
- ユーザー1で、再現手順の手順2で作成した「レポートの詳細」画面を表示します。