001-004676

パッケージ版 Garoon

関心あり
2人の方が関心を示しています

承認された申請を申請者が確認する前に運用管理者が削除すると、申請者の通知一覧に消えない通知が残る。

種別
不具合
機能
  • ワークフロー
再現バージョン
  • 2.1.0
  • 2.1.1
  • 2.1.2
  • 2.1.3
  • 2.5.0
  • 2.5.1
  • 2.5.2
  • 2.5.3
  • 2.5.4
  • 3.0.0
  • 3.0.1
  • 3.0.2
  • 3.0.3
  • 3.1.0
  • 3.1.1
改修バージョン
3.1.2
公開日
2011-07-05
更新日
2011-08-19

詳細

【発生条件】


次の条件をすべて満たす場合に発生します。

  • 次いずれかの「状況」である。
    • 承認
    • 完了
    • 差し戻し
    • 却下


  • 上記の申請データが、未確認の通知として存在する。
  • 運用管理画面の「申請データの管理」画面で、上記の申請データを削除する。


【準備】

  • 次のように、ユーザーアカウントを作成します。
      例:
    • ユーザー1
    • ユーザー2
    • ユーザー3

  • ワークフローの申請フォームを作成します。


    1. システム管理画面で、[各アプリケーションの管理] > [ワークフロー]> [申請フォームの一覧]を順にクリックします。

    2. 任意のカテゴリで、[申請フォームを追加する]をクリックします。
      例:
      「カテゴリA」

    3. 任意の内容を入力して、[追加する]をクリックします。
      例:
      申請フォーム名:申請フォームA

    4. 「申請フォームの詳細」画面で、承認経路の後に1つ以上の回覧経路を設定します。
      例:
      経路ステップ
      承認経路:「承認A」
      回覧経路:「回覧A」

    5. [有効にする]をクリックして、申請フォームAを有効にします。

    6. 「運用管理権限の設定」画面を開きます。

    7. カテゴリAをクリックします。

    8. [設定する]をクリックします。

    9. 運用管理者にユーザー3を追加します。

【再現手順】

  1. アプリケーション画面に、ユーザー1でログインします。

  2. [ワークフロー] > [申請する] > [カテゴリA] > [申請フォームA]を順にクリックします。

  3. フォームに任意の内容を入力して、[経路を設定する >> ]をクリックします。

  4. 申請経路の承認者と回覧者にユーザー2を選択して、[申請する]をクリックします。

  5. アプリケーション画面に、ユーザー2でログインします。

  6. 手順4の申請を承認します。

  7. アプリケーション画面に、ユーザー1でログインし、通知が届くことを確認します。

  8. アプリケーション画面に、ユーザー3でログインします。

  9. [ワークフロー] > [申請データの管理] > [カテゴリA] > [申請フォームA] > [削除する] > [はい]の順にクリックして、手順4の申請データを削除します。

     補足:
     運用管理画面から申請データを削除します。

  10. アプリケーション画面に、ユーザー1でログインし、通知一覧を確認します。


→現象発生:

 削除された申請データのワークフローの通知が表示されます。

 

 補足:

  • ワークフローを確認できないので、通知が削除できません。
  • 通知をクリックすると、次のエラーが表示されます。
    ------------------------------- 
    エラー (GRN_WRKF_25302)
    指定された申請データが見つかりません。
    原因
    申請の指定データが誤っているか、指定された申請データは削除されています。
    -------------------------------

回避/対応方法

【回避方法】

 

バージョン3.0.0 以降のガルーンの場合:

  • 申請データを削除する場合、システム管理画面からデータを削除します。

    1. 再現手順9でシステム管理画面で、申請データを削除します。
      例:
      [システム管理] > [各アプリケーションの管理] > [ワークフロー] > [申請データの管理] > [カテゴリA] > [申請フォームA] > [削除する] > [はい]

 

【対応方法】

  • 通知の一括削除を使用します。


    1. アプリケーション画面で、[個人設定] > [各アプリケーションの設定] > [通知一覧] > [通知の一括削除]の順にクリックします。

    2. 現象が発生した通知の日付を含む期間を指定します。

    3. [削除する]をクリックします。

      補足:
      通知の一括削除では、指定した日付より前の通知がすべて削除されます。