001-005484
「繰り返しの施設予約」を許可していない施設が、繰り返し予定の登録画面に表示される。
- 種別
- 不具合
- 機能
-
- スケジュール
- 再現バージョン
-
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 改修バージョン
- 3.5.0
- 公開日
- 2012-02-06
- 更新日
- 2012-02-24
詳細
【発生条件】
次の条件をすべて満たす場合に発生します。
- 「繰り返しの施設予約」を許可しない設定となっている施設グループが存在する。
- 上記の施設グループ以下に施設が存在し、予約設定を親施設グループから継承している。
【再現手順】
- システム管理画面にログインし、[各アプリケーションの管理] > [スケジュール] > [施設/施設グループ] > [子施設グループを追加する]の順にクリックします。
- 施設グループを追加します。
例:
施設グループ名:施設グループA - [施設グループA] > [施設を追加する]をクリックし、作成した施設グループ以下に施設を追加します。
例:
施設名:施設A - [各アプリケーションの管理] > [スケジュール] > [施設予約の設定] > [施設グループA] > [施設グループA]の順にクリックします。
- 「親施設グループの内容を反映する」のチェックを外します。
- 「繰り返しの施設予約」のチェックを外し、[変更する]をクリックします。
- [施設A]をクリックし、「親施設グループの内容を反映する」のチェックが有効になっていることを確認します。
- アプリケーション画面にログインし、[スケジュール] > [予定を登録する] > [繰り返し予定]の順にクリックし、施設を選択します。
→現象発生:
「施設A」が選択候補に表示され、[←追加]で選択できます。
→正しい結果:
「施設A」は選択候補に表示されません。
補足:
- 「施設A」を選択した状態で[登録する]をクリックすると、次のエラーが表示され予定を登録できません。
-------------------
エラー (GRN_SCHD_13226)
指定された施設は使用できません。
原因
現在ログイン中のユーザーには、この施設を使用して、予定を作成/変更する権限がありません。
-------------------
このエラーが表示されるのは正常動作です。
回避/対応方法
【回避方法】
次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。
- バージョン 3.5.0 のガルーン