001-006009
拠点に設定したカレンダーを削除し、その拠点をユーザーに設定すると、エラーが発生しユーザーの追加ができない。
- 種別
- 不具合
- 機能
-
- システム設定
- 再現バージョン
-
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.5.0
- 3.5.1
- 3.5.2
- 改修バージョン
- 3.5.3
- 公開日
- 2012-11-01
- 更新日
- 2012-11-29
詳細
【準備】
- カレンダーを登録します。
例:
カレンダー1 - カレンダーに「カレンダー1」を選択した拠点を設定します。
例:
拠点名:拠点1
カレンダー:カレンダー1
【再現手順】
- システム管理画面にログインし、[基本システムの管理] > [カレンダー] > [カレンダーの設定] >[カレンダー1] > [詳細]の順にクリックします。
- [削除する]をクリックします。
- [はい]をクリックします。
- [基本システムの管理] > [組織/ユーザーの設定] > [ユーザーを追加する]の順にクリックします。
- 拠点に「拠点1」を選択し、他の項目を任意で入力し[追加する]をクリックします。
例:
名前:ユーザー1
ログイン名:user1
拠点:拠点1
→現象発生:
次のエラーが発生し、ユーザーの追加ができません。
----------------------------
エラー (DB01452)
外部キー制約のためにオブジェクトを追加できません。
原因
Cannot add or update a child row: a foreign key constraint fails (`cb_cbgrn`.`tab_cb_user_base_setting`, CONSTRAINT `cns_cb_user_base_setting_calendar` FOREIGN KEY (`col_calendar`) REFERENCES `tab_grn_systemcalendar` (`_id`) ON DELETE SET NULL)
----------------------------
補足:
- 既存のユーザーに拠点1を設定し変更した場合も、同様の現象が発生します。
回避/対応方法
【回避方法】
手順3のあと拠点1の「拠点の変更」画面を表示し、存在するカレンダーを選択して[設定する]をクリックします。