001-006072
  					  
			  		  ワークフローの「カテゴリの追加」画面で、必須項目を空欄にしたまま[追加する]をクリックすると、「親カテゴリ」欄のカテゴリー名が消える。
- 種別
 - 不具合
 - 機能
 - 
		  						
- ワークフロー
 - システム設定
 
 - 再現バージョン
 - 
	  							
- 2.1.0
 - 2.1.1
 - 2.1.2
 - 2.1.3
 - 2.5.0
 - 2.5.1
 - 2.5.2
 - 2.5.3
 - 2.5.4
 - 3.0.0
 - 3.0.1
 - 3.0.2
 - 3.0.3
 - 3.1.0
 - 3.1.1
 - 3.1.2
 - 3.1.3
 - 3.5.0
 - 3.5.1
 - 3.5.2
 - 3.5.3
 - 3.5.4
 - 3.5.5
 - 3.7.0
 - 3.7.1
 - 3.7.2
 - 3.7.3
 - 3.7.4
 - 3.7.5
 - 4.0.0
 - 4.0.1
 - 4.0.2
 - 4.0.3
 - 4.2.0
 - 4.2.1
 - 4.2.2
 - 4.2.3
 
 - 改修バージョン
 - 4.2.4
 - 公開日
 - 2013-05-29
 - 更新日
 - 2016-11-25
 
詳細
【準備】
- ワークフローのカテゴリを追加します。
例:
カテゴリ1 
【再現手順】
- システム管理画面にログインし、[各アプリケーションの管理] > [ワークフロー] > [申請フォームの一覧] > [カテゴリ1] > [カテゴリを追加する]の順にクリックします。
 - 「親カテゴリ」欄に「カテゴリ1」と表示されていることを確認します。
 - 必須項目を空欄にしたままで、[追加する]をクリックします。
例:
------------
タイトル(標準):(空欄)
カテゴリコード:カテゴリコード1-1
------------ 
→現象発生:
「親カテゴリ」欄の「カテゴリ1」が消えます。
補足:
- 現象が発生した状態で必須項目を入力し、[追加する]をクリックした場合の挙動は、次の通りです。
バージョン 2.1.0~3.0.3のガルーンの場合:
「カテゴリ1」の子カテゴリとして、正常にカテゴリの追加が完了します。
バージョン 3.1.0以降のガルーンの場合:
次のエラーが発生し、カテゴリを追加できません。
------------
エラー (GRN_WRKF_25000)
カテゴリIDが不正です。
原因
カテゴリの指定が誤っているか、カテゴリが削除されています。
------------ - 手順3でタイトルとカテゴリコードのどちらも空欄にした場合、またはカテゴリコードのみ空欄にした場合も、同様の現象が発生します。
 
- 親カテゴリが「(ルート)」の場合も、同様の現象が発生します。
 - バージョン 2.1.0~3.1.3、またはバージョン 3.5.1以降のガルーンの場合、(運用管理画面)「ワークフロー > 申請フォームの一覧 > カテゴリの追加」画面でも、同様の現象が発生します。
 
回避/対応方法
【回避方法】
次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。
- バージョン 4.2.4のガルーン
 
-------------------------------------------------------------
【更新履歴】
2016/11/10 タイトルを更新しました。