001-008287
「ユーザー情報の変更」画面でバリデーションエラーが発生すると、優先する組織を正しく更新できない場合がある。
- 種別
- 不具合
- 機能
-
- システム設定
- 再現バージョン
-
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.5
- 3.7.0
- 3.7.1
- 3.7.2
- 3.7.3
- 3.7.4
- 3.7.5
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.10.0
- 4.10.1
- 4.10.2
- 4.10.3
- 5.0.0
- 5.0.1
- 5.0.2
- 5.5.0
- 5.5.1
- 5.9.0
- 5.9.1
- 5.9.2
- 5.15.0
- 5.15.1
- 5.15.2
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 改修バージョン
- 公開日
- 2016-11-18
- 更新日
- 2016-11-18
詳細
【発生条件】
次の条件をすべて満たす場合に発生します。
- ユーザーが複数の組織に所属している。
- 「ユーザーの詳細」画面の「所属する組織」の中で、2番目以降に表示されている組織が「優先する組織」に指定されている。
例:
---------------------
所属する組織:組織1
組織2
優先する組織:組織2
--------------------- - ユーザー情報を変更する時に、バリデーションエラーが発生している。
【準備】
- 2つ以上の組織を追加します。
例:
- 組織1
- 組織2
- ユーザーを追加します。
例:
ユーザー1 - ユーザー1を「組織1」「組織2」に所属させ、優先する組織を「組織2」に設定します。
例:
---------------------
所属する組織:組織1
組織2
優先する組織:組織2
---------------------
補足:
- 「ユーザーの詳細」画面で、「組織2」が2番目に表示されている状態とします。
【再現手順】
- システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [組織/ユーザーの設定]の順にクリックします。
- [組織1] > [ユーザー1] > [変更する]の順にクリックします。
- 「名前」を空欄にして[変更する]をクリックし、バリデーションエラーを発生させます。
- 「名前」を入力し、[変更する]をクリックします。
例:
---------------------
名前:ユーザー1
優先する組織:組織2
---------------------
補足:
- 優先する組織は「組織2」のままにします。
→現象発生:
優先する組織が「組織1」になります。
補足:
- 次のエラーが発生し、ユーザー情報を更新できない場合もあります。
---------------------
エラー (GRN_CMMN_00109)
「優先する組織」の設定に失敗しました。
原因
ユーザーが所属していない組織を「優先する組織」に設定できません。
---------------------
回避/対応方法
【対応方法】
「ユーザー情報の変更」画面を開きなおし、バリデーションエラーが発生していない状態で組織を設定します。