001-008503

パッケージ版 Garoon

関心あり
0人の方が関心を示しています。

[CyVDB-722]APIに関するSQLインジェクションの脆弱性

種別
脆弱性
機能
  • ユーザー
  • SOAP API
再現バージョン
  • 3.7.0
  • 3.7.1
  • 3.7.2
  • 3.7.3
  • 3.7.4
  • 3.7.5
改修バージョン
4.0.0
公開日
2014-11-28
更新日
2014-11-28

攻撃者にこの脆弱性を利用された場合、SQLコマンドを実行され、データの取得や改ざんなどの被害を引き起こされる可能性があります。
本脆弱性は、API利用時に発生します。

脆弱性タイプ:

  • SQLインジェクション

 

脆弱性の基本評価:

  • 攻撃元区分(AV):ネットワーク
  • 攻撃条件の複雑さ(AC):低
  • 攻撃前の認証要否(Au):単一 (攻撃前に認証(ログイン等)が必要である)
  • 機密性への影響(C):部分的(一部の機密情報が参照可能である)
  • 完全性への影響(I):部分的(一部の情報が改ざん可能である)
  • 可用性への影響(A):部分的(業務の遅延や一時中断が可能である)

 

CVSS基本値:

  • 6.5(レベルⅡ)

 

補足:


【回避方法】

次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。

  • バージョン4.0.0のガルーン

関連記事