001-009302
「アクセス権の設定」画面で、「組織/ユーザー」の[+]や[-]をクリックすると、エラー(GRN_CMMN_00004)が発生する場合がある。
- 種別
- 不具合
- 機能
-
- スケジュール
- 電話メモ
- システム設定
- 再現バージョン
-
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.2.0
- 改修バージョン
- 4.2.1
- 公開日
- 2016-01-13
- 更新日
- 2016-02-26
詳細
【発生条件】
次の条件をすべて満たす場合に発生します。
- 次のどちらかまたは両方に該当するユーザーで、利用が許可されていないアプリケーションのアクセス権の設定を行う。
- スケジュールの利用が許可されていない、かつ、スケジュールの管理権限を持つユーザー
- 電話メモの利用が許可されていない、かつ、電話メモの管理権限を持つユーザー
- スケジュールの利用が許可されていない、かつ、スケジュールの管理権限を持つユーザー
- 子組織を持つ組織が存在する。
【準備】
- ユーザーを追加します。
例:
ユーザー1 - 子組織を持つ組織を追加します。
例:
組織1
└組織1-1 - ユーザー1に、スケジュールの管理権限を追加します。
補足:
- (システム管理画面)「管理権限 > アプリケーションの管理権限」画面で設定します。
- (システム管理画面)「管理権限 > アプリケーションの管理権限」画面で設定します。
- ユーザー1に対し、スケジュールの利用を許可しない設定にします。
例:
------------------------
対象:ユーザー1
利用を許可するアプリケーション:「スケジュール」のチェックボックスの選択を外す
------------------------
補足:
- (システム管理画面)「アプリケーション > 利用ユーザーの設定」画面で設定します。
【再現手順】
- システム管理画面にユーザー1でログインし、[各アプリケーションの管理] > [スケジュール] > [アクセス権の設定] > [組織/ユーザー]の順にクリックします。
- 組織1の左にある[+]または[-]をクリックします。
→現象発生:
次のエラーが発生し、ツリーが展開または格納できません。
------------------------
エラー (GRN_CMMN_00004)
アプリケーションを使用できません。
原因
アプリケーションが使用停止中になっているか、現在ログイン中のユーザーが使用を許可されていません。
------------------------
補足:
- 電話メモの場合は、次の画面で手順2と同じ操作をすると現象が発生します。
- (システム管理画面)「電話メモ > アクセス権の設定 > 組織/ユーザー」画面
- (システム管理画面)「電話メモ > アクセス権の設定 > 組織/ユーザー」画面
- ユーザー1を含むロールや組織にスケジュールまたは電話メモの利用権限を許可しない場合も、同様の現象が発生します。
例:
------------------------
対象:Everyone
利用を許可するアプリケーション:「スケジュール」のチェックボックスの選択を外す
------------------------
回避/対応方法
【回避方法】
組織名のリンクや[(トップ)]をクリックし、ツリーを展開または格納します。
例:
------------------------
組織1
------------------------