001-009465
ケータイで、アドレス帳検索を使用した宛先が2つ以上指定されているメールを送信しようとすると、エラー(GRN_MAIL_24604)が発生する。
- 種別
- 不具合
- 機能
-
- メール
- ケータイ
- 再現バージョン
-
- 4.0.1
- 4.0.2
- 4.0.3
- 4.2.0
- 4.2.1
- 改修バージョン
- 4.2.2
- 公開日
- 2016-03-25
- 更新日
- 2016-05-27
詳細
【準備】
- ユーザーを追加します。
例:
ユーザー1 - ユーザー1の個人アドレス帳に、2つ以上のアドレスを登録します。
例:
- 表示名:ユーザー2
E-mail:user2@xxxxx.co.jp - 表示名:ユーザー3
E-mail:user3@xxxxx.co.jp
- 表示名:ユーザー2
【再現手順】
- ユーザー1で、ケータイにログインします。
- [メール] > [メール作成]の順にクリックします。
- To欄の[検索]をクリックします。
- 検索文字列に「ユーザー2」を入力し、[検索]をクリックします。
- 検索結果の[user2@xxxxx..]をクリックします。
- 再度、To欄の[検索]をクリックします。
- 検索文字列に「ユーザー3」を入力し、[検索]をクリックします。
- 検索結果の[user3@xxxxx..]をクリックします。
- [確認] > [送信]の順にクリックします。
→現象発生:
次のエラーが発生し、メールを送信できません。
バージョン 4.0.3以前のガルーンの場合:
------------------------
エラー(GRN_MAIL_24604)
メールの送信に失敗しました。
------------------------
バージョン 4.2.0以降のガルーンの場合:
------------------------
エラー(GRN_MAIL_24604)
メールの送信に失敗しました。
原因
送信先のメールアドレスに不正な文字列が含まれています。
------------------------
補足:
- 準備で、共有アドレス帳に、2つ以上のアドレスを登録した場合にも、同様の現象が発生します。
- Cc欄、Bcc欄に、アドレス帳検索を使用して2つ以上のアドレスを指定した場合にも、同様の現象が発生します。
回避/対応方法
【回避方法】
宛先で、不要に挿入された改行を削除したあと、メールを送信します。
例:
- 変更前:
------------------------
user2@xxxxx.co.jp,
user3@xxxxx.co.jp
------------------------ - 変更後:
------------------------
user2@xxxxx.co.jp,user3@xxxxx.co.jp
------------------------
------------------------------------------------------------
【更新履歴】
2016/05/17 タイトルを更新しました。