001-008274
ポータルの管理権限を持つユーザーが、スケジュールポートレットの設定画面で施設を検索すると、エラーが発生する場合がある。
- 種別
- 不具合
- 機能
-
- ポータル
- ポートレット
- スケジュール
- 再現バージョン
-
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.10.0
- 4.10.1
- 4.10.2
- 4.10.3
- 5.0.0
- 5.0.1
- 5.0.2
- 5.5.0
- 5.5.1
- 5.9.0
- 5.9.1
- 5.9.2
- 5.15.0
- 5.15.1
- 5.15.2
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 改修バージョン
- 公開日
- 2021-06-17
- 更新日
- 2021-06-17
詳細
【準備】
- ユーザーを追加します。
例:
ユーザー1
- 施設グループを追加します。
例:
施設グループ1 - ユーザー1に、ポータルのアプリケーション管理権限を追加します。
例:
----------------
対象:ユーザー1
管理項目:ポータル
----------------
補足:
- (システム管理画面)「管理権限 > アプリケーションの管理権限 > アプリケーションの管理権限の追加」画面で追加します。
- (システム管理画面)「管理権限 > アプリケーションの管理権限 > アプリケーションの管理権限の追加」画面で追加します。
- ポータルを追加します。
例:
ポータル1 - ポータル1に、次のいずれかのスケジュールポートレットを追加します。
- スケジュール(日表示)
- スケジュール(週表示)
- スケジュール(月表示)
【再現手順】
- ユーザー1でシステム管理画面にログインし、[各アプリケーションの管理] > [ポータル] > [ポータルの一覧] > [ポータル1]の順にクリックします。
- 準備で追加したスケジュールポートレットの[設定]をクリックします。
- [施設検索]をクリックします。
→現象発生:
次のエラーが発生します。
----------------
エラー (GRN_CMMN_00005)
処理を実行できません。
原因
システム管理を行う権限がありません。
----------------
補足:
- 手順2のあとに、ドロップダウンダウンリストで施設グループを選択する場合も、同様のエラーが発生します。
- 次のバージョンの場合、エラーは発生せず、検索結果が表示されない状態になります。
バージョン 4.0.0からバージョン 4.2.XのGaroon
回避/対応方法
【対応方法】
ユーザー1にスケジュールのアプリケーション管理権限を追加すると、施設を検索できるようになります。
- システム管理画面にログインし、[基本システムの管理] > [管理権限] > [アプリケーションの管理権限]の順にクリックします。
- ユーザー1の[変更]をクリックします。
- 「スケジュール」のチェックボックスを選択し、[変更する]をクリックします。