001-011133
Garoon 3で削除した申請データの既読通知が、バージョンアップしても削除されず、通知一覧に表示されてしまう場合がある。
- 種別
- 不具合
- 機能
-
- ワークフロー
- 再現バージョン
-
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.5
- 3.7.0
- 3.7.1
- 3.7.2
- 3.7.3
- 3.7.4
- 3.7.5
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.10.0
- 4.10.1
- 4.10.2
- 4.10.3
- 5.0.0
- 5.0.1
- 5.0.2
- 5.5.0
- 5.5.1
- 5.9.0
- 5.9.1
- 5.9.2
- 改修バージョン
- 5.15.0
- 公開日
- 2022-08-19
- 更新日
- 2022-10-28
詳細
【発生条件】
次の条件を満たす場合に発生します。
次の条件を満たす場合に発生します。
- バージョン 3.0.0~3.1.1のGaroonで次の不具合が発生し、削除した申請データの既読通知が残っている。
システム管理画面で申請データを削除したとき、削除した申請データの確認済み通知が残る場合がある。
https://kb.cybozu.support/article/29973/
【準備】
- バージョン 3.0.0~3.1.1のいずれかのGaroonに、ユーザーを追加します。
例:
ユーザー1 - 発生条件を満たす状態にします。
補足:- ユーザー1の通知一覧に、削除した申請データの既読通知が残っている状態にします。
- Garoonのインストーラーを起動し、バージョンアップを実行します。
- ユーザー1でアプリケーション画面にログインし、[通知一覧] > [既読]の順にクリックします。
→現象発生:
削除した申請データの既読通知が、削除されずに表示されています。
→正しい結果:
削除した申請データの既読通知は削除され、表示されません。
補足:
- 削除した申請データの既読通知をクリックすると、次のエラーが発生します。
-------------------------------
エラー (GRN_WRKF_25302)
指定された申請データが見つかりません。
原因
申請の指定データが誤っているか、指定された申請データは削除されています。
------------------------------- - 手順2でベルアイコン、または次のポートレットから通知を確認した場合も、同様の現象が発生します。
- 「通知一覧」ポートレット
- 「確認済みの通知」ポートレット
回避/対応方法
【回避方法】
次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。
次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。
- バージョン 5.15.0のGaroon