001-011223

パッケージ版 Garoon

関心あり
0人の方が関心を示しています

全文検索サーバー利用時、ファイルが添付された未読メールを開封しようとすると、エラーが発生してメールの詳細が表示されない場合がある。

種別
不具合
機能
  • 全般
  • メール
再現バージョン
  • 4.0.0
  • 4.0.1
  • 4.0.2
  • 4.0.3
  • 4.2.0
  • 4.2.1
  • 4.2.2
  • 4.2.3
  • 4.2.4
  • 4.2.5
  • 4.2.6
  • 4.6.0
  • 4.6.1
  • 4.6.2
  • 4.6.3
  • 4.10.0
  • 4.10.1
  • 4.10.2
  • 4.10.3
  • 5.0.0
  • 5.0.1
  • 5.0.2
  • 5.5.0
  • 5.5.1
  • 5.9.0
  • 5.9.1
  • 5.9.2
改修バージョン
5.15.0
公開日
2022-10-07
更新日
2022-10-28

詳細

【発生条件】
パターン1:
次の条件をすべて満たすと発生する場合があります。
  • 全文検索サーバーを利用している。
  • ファイルが添付されたメールを既読にしたあと、cleanup.cspが実行される前にMySQLサービスを再起動し、ファイルが添付された未読メールを開封しようとする。
パターン2:
次の条件をすべて満たすと発生する場合があります。
  • 全文検索サーバーを利用している。
  • cleanup.cspの実行に失敗したあと、ファイルが添付された未読メールを開封しようとする。

※本記事はパターン1の条件を満たす再現例を記載します。

【準備】
  • 全文検索サーバーをインストールし、Garoonで利用できるよう設定します。

  • ユーザーを追加します。

    例:
    ユーザー1

  • ユーザー1にメールアカウントを設定します。

  • ユーザー1で、ファイルが添付されたメールを複数受信します。

    例:
    • メール1
    • メール2

  • ユーザー1でメール1を既読にします。

  • MySQLサービスを再起動します。

    例:
    Windowsの場合:
    Windowsのスタートメニューから、[管理ツール] > [サービス]の順にクリックし、次のサービスを再起動します。
    • Cybozu_Database_Engine_5_0

    Linuxの場合:
    /etc/init.d/cyde_5_0 restart

【再現手順】

  1. ユーザー1でアプリケーション画面にログインし、[メール] > [受信箱] > [メール2]の順にクリックします。

→現象発生:
 次の現象が発生する場合があります。

 2ペイン(プレビュー非表示)の場合:
  • 次のエラーが発生し、「メールの詳細」画面が表示されない場合があります。
    ------------
    エラー (DB01062)
    値が重複しています。
    原因
    Duplicate entry '1' for key 'PRIMARY'
    ------------

 3ペイン(プレビュー表示)の場合:
  • 次のエラーが発生し、メールの詳細が表示されない場合があります。

    バージョン 4.0.0〜4.2.6のGaroonの場合:
    ------------
    エラー (DB01062)
    値が重複しています。
    原因
    Duplicate entry '1' for key 'PRIMARY'
    ------------

    バージョン 4.6.0以降のGaroonの場合:

    • WebサーバーにIISを使用している場合:

      例:
      エラーメッセージが文字化けした状態で表示されます。
      ------------
      エラー
      502 - Web XXXXXXXXX……
      ------------

    • WebサーバーにApacheを使用している場合:

      例:
      ------------
      500 Internal Server Error Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log.
      ------------

補足:
  • Garoonのバージョンによって、エラーが表示されず、真っ白の画面が表示される場合があります。

回避/対応方法

【対応方法】
お手数ですが、オフィシャルパートナー、または弊社テクニカルサポートにお問い合わせください。