001-011356
サイボウズ共通認証またはオープン統合認証 ver.2を使用したセッション認証で、発行ドメインに無効な文字が含まれていると、エラー(PHP00099)が発生し、Garoonにログインできない場合がある。
- 種別
- 不具合
- 機能
-
- 認証
- 再現バージョン
-
- 5.15.0
- 5.15.1
- 5.15.2
- 6.0.0
- 6.0.1
- 6.0.2
- 改修バージョン
- 改修予定
-
あり
現時点で改修の予定がある不具合には「改修予定 あり」が表示されます。ただし予定通りに改修されない場合もあるため、この表示は改修を確約するものではありません。また、不具合の具体的な改修時期についてはお伝えできません。
- 公開日
- 2024-06-07
- 更新日
- 2024-06-07
詳細
【発生条件】
次の条件をすべて満たすと発生する場合があります。
次の条件をすべて満たすと発生する場合があります。
- セッション認証で、サイボウズ共通認証またはオープン統合認証 ver.2を使用する。
- セッション認証の発行ドメインに、次のいずれかの無効な文字が含まれている。
- 「,」(半角カンマ)
- 「;」(半角セミコロン)
- 「 」(半角スペース)
- 「\t」(タブ)
- 「\r」(キャリッジリターン)
- 「\n」(改行コード)
- 「\013」(垂直タブ)
- 「\014」(フォームフィード)
【準備】
- 次のようなセッション認証を追加し、認証を有効にします。
例:
---------------
セッション認証名:認証1
セッション認証形式:オープン統合認証 ver.2
モード:サイボウズ共通認証
発行ドメイン:xx.xx.xx.xx;path=test,1;
---------------
補足:- モードに「サイボウズ共通認証」を選択し、発行ドメインのpathに「,」(半角カンマ)を入力します。
- 発行ドメインは、解析する際に「;」(セミコロン)で分割され、第一階層がdomain、第二階層がpathとなります。
- モードに「サイボウズ共通認証」を選択し、発行ドメインのpathに「,」(半角カンマ)を入力します。
【再現手順】
- アプリケーション画面のログインURLにアクセスします。
例:
Windowsの場合:
http://(サーバーのIPアドレスまたはホスト名)/scripts/cbgrn/grn.exe
Linuxの場合:
http://(サーバーのIPアドレスまたはホスト名)/cgi-bin/cbgrn/grn.cgi - ログイン名とパスワードを入力し、[ログイン]をクリックします。
→現象発生:
次のエラーが発生し、ログインできません。
次のエラーが発生し、ログインできません。
---------------
エラー (PHP00099)
予期しないエラーが発生しました。
原因
原因は不明です。
---------------
補足:
エラー (PHP00099)
予期しないエラーが発生しました。
原因
原因は不明です。
---------------
補足:
- 準備1点目で、発行ドメインのdomainに無効な文字を入力しても、同様の現象が発生する場合があります。
例:
発行ドメインのdomainに「,」(半角カンマ)を入力する。
---------------
発行ドメイン:xx.xx.xx.xx,
--------------- - 準備1点目で、セッション認証のモードを「オープン統合認証 ver.2」に設定していると、認証を有効にした際にエラー (PHP00099)となる現象が発生する場合があります。
このとき、システム管理画面とアプリケーション画面のどちらにアクセスした場合も、エラー (PHP00099)が発生し、ログインできません。
回避/対応方法
【回避方法】
システム管理画面にログインし、発行ドメインの無効な文字を削除します。
例:
Windowsの場合:
http://(サーバーのIPアドレスまたはホスト名)/scripts/cbgrn/grn.exe/system/index
Linuxの場合:
http://(サーバーのIPアドレスまたはホスト名)/cgi-bin/cbgrn/grn.cgi/system/index
【対応方法】
次のどちらかの方法で対応できます。
システム管理画面にログインし、発行ドメインの無効な文字を削除します。
例:
Windowsの場合:
http://(サーバーのIPアドレスまたはホスト名)/scripts/cbgrn/grn.exe/system/index
Linuxの場合:
http://(サーバーのIPアドレスまたはホスト名)/cgi-bin/cbgrn/grn.cgi/system/index
【対応方法】
次のどちらかの方法で対応できます。
- セッション認証のモードを「サイボウズ共通認証」に設定している場合:
「回避方法」と同じ手順です。 - セッション認証のモードを「オープン統合認証 ver.2」に設定している場合:
すでに現象が発生している場合は、データベースに保存された設定値の変更が必要です。
お手数ですが、オフィシャルパートナー、または弊社テクニカルサポートにお問い合わせください。