001-005671

パッケージ版 Garoon

関心あり
0人の方が関心を示しています。

ワークフローを再初期化していると、3.5.0へのバージョンアップに失敗する場合がある。

種別
不具合
機能
  • ワークフロー
再現バージョン
  • 3.5.0
改修バージョン
公開日
2012-03-13
更新日
2013-12-06

【発生条件】

 

次の条件をすべて満たす場合に発生します。

  • バージョン 2.1.1以前のガルーンからバージョンアップしている。

  • バージョン 2.1.2以降のガルーンでワークフローを再初期化している。

 

【準備】

  1. バージョン 2.1.1 のガルーンをインストールします。

  2. バージョン 2.1.3 のガルーンへバージョンアップします。

  3. バージョン 2.1.3 のガルーンのシステム管理画面にログインします。

  4. [基本システムの管理] > [アプリケーション] > [アプリケーション一覧]の順にクリックします。

  5. 「ワークフロー」の[再初期化] > [OK]をクリックします。

 

【再現手順】

  1. バージョン 3.5.0 のガルーンへバージョンアップします。

 

    →現象発生:
     次のエラーが表示され、バージョンアップに失敗します。
     ----------------
     バージョンアップスクリプトが異常終了しました。(4) サイボウズオフィシャルパートナー、または販売元にお問い合わせください。
     ----------------

     

    補足:

    • バージョン 3.7.0へのバージョンアップ時には、本現象は発生しません。

    【回避方法】

     

    バージョンアップ前のデータで次の不具合を解消した状態であれば、バージョン 3.5.0 へバージョンアップすることができます。

      ワークフローを再初期化して経路を追加すると、エラーが発生し経路を追加できない場合がある。
      https://kb.cybozu.support/article/29729/

    ただし上記不具合を回避するためには内部データの変更が必要です。
    お手数ですが、オフィシャル パートナー、または弊社テクニカルサポートにお問い合わせください。

     

    補足:

    • バージョンアップ経路の中に、2.1.3から2.5.0へのバージョンアップが含まれている場合は、次の原因でバージョンアップに失敗している可能性があります。

      lwc.iniにデータベースのポート番号が設定されていない場合、ガルーン 3.5.0へのバージョンアップに失敗する。
      https://kb.cybozu.support/article/30434/

      この場合は、次のエラーが表示されます。(カッコの中に表示される数字が異なります。)
      ----------------
      バージョンアップスクリプトが異常終了しました。(2) サイボウズオフィシャルパートナー、または販売元にお問い合わせください。
      ----------------

     

    【対応方法】

     

    すでに現象が発生している場合はバージョンアップ前の環境を再構築し、【回避方法】の手順を実施した後に再度バージョンアップを実施してください。

     

     

    ------------------------------------------------------------
    【更新履歴】

    2013/12/06 回避方法のURLを変更しました。

    関連ワード

    350Attention