001-006020

パッケージ版 Garoon

関心あり
0人の方が関心を示しています

スペースのメモを最後に更新したユーザーが削除されても、「更新者」欄のユーザー名がリンクになっている。

種別
不具合
機能
  • スペース
  • ユーザー
再現バージョン
  • 3.5.0
  • 3.5.1
  • 3.5.2
  • 3.5.3
  • 3.5.4
  • 3.5.5
  • 3.7.0
  • 3.7.1
  • 3.7.2
  • 3.7.3
  • 3.7.4
  • 3.7.5
  • 4.0.0
  • 4.0.1
  • 4.0.2
  • 4.0.3
  • 4.2.0
  • 4.2.1
  • 4.2.2
  • 4.2.3
改修バージョン
4.2.4
公開日
2013-02-15
更新日
2016-11-25

詳細

【準備】

  • ユーザーを追加します。

    例:
    • ユーザー1
    • ユーザー2

  • メンバーに、ユーザー1を含むスペースを作成します。

    例:
    --------------
    スペース名:スペース1
    メンバー:ユーザー1、ユーザー2
    --------------

 

【再現手順】

  1. ユーザー1でアプリケーション画面にログインし、[スペース] > [スペース1]の順にクリックします。

  2. 画面右側の「メモ」アイコンをクリックし、「メモを変更する」アイコンをクリックします。

  3. メモを任意に変更し、[変更する]をクリックします。

  4. システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [組織/ユーザーの設定]の順にクリックします。

  5. ユーザー1を検索し、[ユーザー1] > [削除する] > [はい]の順にクリックします。

  6. ユーザー2でアプリケーション画面にログインし、[スペース] > [スペース1]の順にクリックします。

 

→現象発生:

 削除されたユーザーであるにもかかわらず、「更新者」欄のユーザー名がリンクになっています。

 例:
 --------------
 ユーザー1(削除されたユーザー)
 --------------

 


補足:

  • リンクをクリックした場合の挙動は、次の通りです。

    手順4で「削除されたユーザーのデータ」が削除予定の場合:
    次のエラーが発生します。
    ---------
    エラー (GRN_CMMN_00105)
    指定されたユーザーが見つかりません。

    原因
    ユーザーの指定が誤っているか、ユーザーが削除されています。
    ---------

    手順4で「削除されたユーザーのデータ
    」が完全削除されている場合
    ログインユーザー(ユーザー2)の「ユーザー情報の詳細」画面が表示されます。

  • 「削除されたユーザーのデータ」の状態は次の操作で確認できます。

    1. システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。

    2. データを削除するユーザーで、 「ユーザー1」が表示されているかどうか確認します。

回避/対応方法

【回避方法】

 

次のバージョンの製品で本現象を改修しています。バージョンアップを検討してください。
  • バージョン 4.2.4のガルーン

 

 

-------------------------------------------------------------
【更新履歴】
2016/11/02 タイトルを更新しました。