001-006047
ワークフロー、マルチレポートまたはケータイの利用ユーザーを追加するとき、使用を停止したユーザーが利用ユーザーにカウントされる。
- 種別
- 不具合
- 機能
-
- ワークフロー
- マルチレポート
- ケータイ
- ライセンス
- 再現バージョン
-
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.5.0
- 3.5.1
- 3.5.2
- 改修バージョン
- 3.5.3
- 公開日
- 2012-09-21
- 更新日
- 2012-09-28
詳細
【準備】
- ガルーンをインストールします。
- システム管理画面にログインし、[基本システムの管理] > [ライセンス] >[ライセンスの管理] > [ライセンスを登録する]の順にクリックします。
- 次のライセンスキーを入力し、[登録する]をクリックします。
ライセンスの種類:新規ユーザーライセンス
ユーザー数:50 - [システム管理(基本システム)] > [ユーザー] > [組織/ユーザーの設定] > [ユーザーを追加する]の順にクリックし、次の51ユーザー(うち、1ユーザーを使用停止にします。)を追加します。
- ユーザー1
- ユーザー2
- ユーザー3
:
: - ユーザー50(使用停止ユーザー)
- ユーザー51
補足:
- 本記事はバージョン 3.0.0のガルーンを例に手順を記載しています。
- バージョン 2.5.4以前のガルーンの場合は、「新規ユーザーライセンス」の他に「新規ワークフローライセンス」が必要です。
【再現手順】
- システム管理画面にログインし、[各アプリケーションの管理] > [ワークフロー] > [利用ユーザーの設定]の順にクリックします。
- 「各組織」から次のユーザーを選択して[←追加]をクリックします。
- ユーザー1
- ユーザー2
- ユーザー3
:
: - ユーザー50(使用停止ユーザー)
- 再度「利用ユーザーの設定」画面を表示し、「各組織」から次のユーザーを選択して[←追加]をクリックします。
- ユーザー51
→現象発生:
- 使用停止ユーザーも必要ライセンス数にカウントされ、ユーザー51をワークフローの利用ユーザーに追加できません。
- 次のエラーが表示されます。
--------------------------------------
エラー (GRN_WRKF_25605)
利用ユーザーを追加できません。
原因
ライセンスで許可されている利用ユーザー数を超えています。
--------------------------------------
→正しい結果:
- 利用停止ユーザーが必要ライセンス数にカウントされず、ユーザー51がワークフローの利用ユーザーに追加されます。
補足:
- 次のアプリケーションでも同様の現象が発生します。
- マルチレポート
次のエラーが表示されます。
--------------------------------------
エラー (GRN_RPRT_31353)
ユーザーを追加できません。
原因
ライセンスで許可されているユーザー数を超えています。
-------------------------------------- - ケータイ
次のエラーが表示されます。
--------------------------------------
エラー (GRN_CLLL_26007)
ユーザーを追加できません。
原因
ライセンスで許可されているユーザー数を超えています。
--------------------------------------
- マルチレポート
回避/対応方法
【対応方法】
次のどちらかの方法によりワークフローの利用ユーザーを追加します。
- 使用停止ユーザーをワークフローの利用ユーザーから削除した後、追加したいユーザーを利用ユーザーに追加する。
- システム管理画面にログインし、[各アプリケーションの管理] > [ワークフロー] > [利用ユーザーの設定]の順にクリックします。
- 「利用権限一覧」からユーザー50のチェックをONにし、[削除する]をクリックします。
- 「各組織」からユーザー51を選択し、[←追加]をクリックします。
- (バージョン 3.5.0以降のガルーンのみ)使用停止ユーザーを含めた組織またはロールを利用ユーザーに追加する。
補足:
- マルチレポート及びケータイもワークフローと同様の対応方法です。