001-011049
メールの送受信にOAuthを使用しているとき、保存されているアクセストークンが無効になり、エラーが発生する場合がある。
- 種別
- 不具合
- 機能
-
- メール
- 再現バージョン
-
- 5.5.1
- 5.9.0
- 改修バージョン
- 5.9.1
- 公開日
- 2021-11-01
- 更新日
- 2022-02-04
詳細
【発生条件】
次の条件をすべて満たす場合に発生します。
- メールの送受信にOAuthを使用する。
- アクセストークンの有効期限が切れている。
- メール送受信のタイミングでアクセストークンを再取得する際、ネットワーク通信の問題などが発生して、以下のエンドポイントに到達できない。
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Microsoft Office 365の場合:https://login.microsoftonline.com/(tenant)/oauth2/v2.0/token
Google Workspace(旧G Suite)の場合:https://oauth2.googleapis.com/token
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【準備】
- ユーザーを追加します。
例:
ユーザー1 - OAuthクライアントを設定します。
補足:- 設定手順の詳細はマニュアルをご確認ください。
管理者ガイド
https://jp.cybozu.help/g5/ja/admin.html
- 設定手順の詳細はマニュアルをご確認ください。
- メールサーバーを追加します。
- ユーザー1にメールアカウントを追加します。
- ユーザー1で、OAuth認可を実行します。
補足:- (個人設定画面)「メール > メールアカウントの設定 > メールアカウントの詳細」画面から実行します。
- (個人設定画面)「メール > メールアカウントの設定 > メールアカウントの詳細」画面から実行します。
【再現手順】
- ユーザー1でアプリケーション画面にログインし、[メール] > [受信]の順にクリックします。
→現象発生:
発生条件2点目、3点目を満たす場合、保存されているアクセストークンが無効になり、次のエラーが発生します。
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エラー (GRN_MAIL_24205)
メールの受信に失敗しました。
原因
メールアカウントが、OAuthの認可サーバーに認可されていません。
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→正しい結果
保存されているアクセストークンが無効にならず、次の正しいエラーが発生します。
補足:
発生条件2点目、3点目を満たす場合、保存されているアクセストークンが無効になり、次のエラーが発生します。
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エラー (GRN_MAIL_24205)
メールの受信に失敗しました。
原因
メールアカウントが、OAuthの認可サーバーに認可されていません。
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→正しい結果
保存されているアクセストークンが無効にならず、次の正しいエラーが発生します。
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エラー (GRN_MAIL_24206)
メールサーバーの認証に失敗しました。
原因
メールサーバーへのアクセスが許可されていません。
メールサーバーからの応答:cURL error 7: Failed connect to login.microsoftonline.com:443; Connection refused (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://login.microsoftonline.com/(tenant)/oauth2/v2.0/token
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補足:
- 手順1で、メールを送信した場合も、同様の現象が発生する場合があります。
回避/対応方法
【対応方法】
ユーザー1で、再度OAuth認可を実行します。
ユーザー1で、再度OAuth認可を実行します。