001-004757
不正な日付のメールが存在する場合、タイムゾーン変更すると、メールを閲覧できなくなる。
- 種別
- 不具合
- 機能
-
- メール
- 再現バージョン
-
- 3.1.0
- 3.1.1
- 3.1.2
- 改修バージョン
- 3.1.3
- 公開日
- 2011-07-28
- 更新日
- 2011-12-26
詳細
【発生条件】
- メールヘッダーの「Date」フィールドが不正な日付のメールが存在する。
- 上記に該当するメールを受信した後に、タイムゾーンを変更した。
【準備】
- タイムゾーンの設定を確認します。
例:「(UTC+09:00)東京」
【再現手順】
- アプリケーション画面で、[個人設定] > [各アプリケーションの設定] > [メール] > [ファイルからの読み込み]の順にクリックします。
- 「発生条件」の内容に該当するメールファイルを読み込みます。
- [個人設定] > [共通設定] > [ローカライズ] > [拠点の設定]の順にクリックします。
- タイムゾーンを変更して、[設定する]をクリックします。
例:「(UTC-11:00)アピーア」 - [メール] をクリックします。
→現象発生:
次のエラーが表示され、メールを閲覧できません。
----------------
エラー (FW00034)
不正な日付時間です。
原因
正常な日付時間を入力してください。
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回避/対応方法
【対応方法】
タイムゾーンの設定を戻し、該当のメールを削除すると、メールを閲覧できます。
- [個人設定] > [共通設定] > [ローカライズ] > [拠点の設定]の順にクリックします。
- タイムゾーンを元の設定に変更して、[設定する]をクリックします。
例:「(UTC+09:00)東京」 - [メール] をクリックします。
- 一覧から該当のメールを選択して、[削除する]をクリックします。