001-006011
ユーザー名の後に優先する組織を表示する設定にしていると、削除予定ユーザーの名前が表示される画面でエラー(GRN_CMMN_00105)が発生する場合がある。
- 種別
- 不具合
- 機能
-
- メッセージ
- ユーザー
- 再現バージョン
-
- 3.5.2
- 改修バージョン
- 3.5.3
- 公開日
- 2012-09-20
- 更新日
- 2014-01-07
詳細
【準備】
- ユーザーを追加します。
例:
- ユーザー1
- ユーザー2
- 組織を追加します。
例:
組織1 - ユーザー1を組織1に所属させます。
【再現手順】
- ユーザー2でアプリケーション画面にログインし、[個人設定] > [共通設定] > [画面] > [一般設定]の順にクリックします。
- ユーザー名の後に表示する情報で「優先する組織」にチェックを入れ、[設定する]をクリックします。
- ユーザー1でアプリケーション画面にログインし、[メッセージ] > [メッセージを送る]の順にクリックします。
- 次の内容を入力し、[送信する]をクリックします。
例:
標題:メッセージ1
宛先:ユーザー2 - システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [組織/ユーザーの設定] > [組織1] > [ユーザー1] > [削除する] > [はい]の順にクリックします。
補足:
- 「削除されたユーザーのデータ」は削除しない状態のままにします。
次の操作で確認できます。
- [基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- データを削除するユーザーで、 「ユーザー1」が表示されていることを確認します。
- [基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- 「削除されたユーザーのデータ」は削除しない状態のままにします。
- ユーザー2でアプリケーション画面にログインし、[メッセージ]をクリックします。
→現象発生:
次のエラーが表示されます。
---------
エラー (GRN_CMMN_00105)
指定されたユーザーが見つかりません。
原因
ユーザーの指定が誤っているか、ユーザーが削除されています。
---------
補足:
- 削除予定ユーザーの名前が表示される画面で、現象が発生する可能性があります。
- 次のアプリケーションで現象が発生することを確認しています。
- ポータル
- 「メッセージ」ポートレット
- 「未確認メッセージ」ポートレット
- 「掲示板」ポートレット
- 「マルチレポート」ポートレット
- 「最新情報」ポートレット
- 「確認済みの通知」ポートレット
- メッセージ
- マルチレポート
- 掲示板
- 通知一覧
- ポータル
回避/対応方法
【対応方法】
次のいずれかの方法で、対応できます。
- ユーザー1のユーザーデータを復旧する。
- システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- 「ユーザー1」にチェックを入れ、[復旧する] > [はい]の順にクリックします。
- システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- ユーザー1のユーザーデータを即時削除する。
- システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- 「ユーザー1」にチェックを入れ、[削除する] > [はい]の順にクリックします。
補足:
ユーザーデータの削除はアクセスの少ない時間帯に行ってください。
- システム管理画面にログインし、[基本システムの管理] > [ユーザー] > [ユーザーデータの削除時間の設定]の順にクリックします。
- ユーザー2の個人設定で、ユーザー名の後に「優先する組織」を表示しない設定にする。
- ユーザー2でアプリケーション画面にログインし、[個人設定] > [共通設定] > [画面] > [一般設定]の順にクリックします。
- ユーザー名の後に表示する情報で「優先する組織」のチェックを外し、[設定する]をクリックします。
- ユーザー2でアプリケーション画面にログインし、[個人設定] > [共通設定] > [画面] > [一般設定]の順にクリックします。
------------------------------------------------------------
【更新履歴】
2014/01/07 タイトルを更新しました。